Aut inveniam viam aut faciam

Carrier Support Carrier (CSC) Notes

\ Carrier Support Carrier (CSC)

ISP1

 – Main ISP

     -> Core ISP

ISP2

 – Second level ISP

     -> Tier 2 ISP

Clients

 – Connected to ISP2

1. ISP1 provides L3VPN connection to ISP2

2. Because of this connection, ISP2 PE routers can ping each other loopback to loopback

3. VPNv4 neighbors between ISP2 PE routers require end-to-end Labeled Switch Path (LSP)

4. The LSP is missing on VRF links of ISP1

     -> CSC-PE to CSC-CE

5. To activate LSP, there are two options

 – If CSC-PE to  CSC-CE protocol is IGP

     -> IGP + label

 – If CSC-PE to CSC-CE protocol is eBGP

     -> eBGP + label

6. For VRF interfaces, if LSP is required, then the only option on XR routers is eBGP

Configuring CSC

 1. Configure ISP1 with L3VPN

 2. Enable communication between ISP2 PE routers

 3. Configure “label processing” between ISP1 and ISP2

 4. Configure L3VPN between ISP2 PE routers

 5. Enable communication between client routers by CSC-CE to CE configuration

 6. In case ISP1 and ISP2 has XR routers, then two things to remember

 – Static route is needed for next-hop IP address between ASBRs

 – Only eBGP supported as VRF + label protocol

! R1

router rip


 version 2

 network 1.0.0.0

! R2

router bgp 200

 address-family ipv4 unicast

  network 2.2.2.2/32

  allocate-label all

 neighbor 23.0.0.3

  remote-as 100


  address-family ipv4 labeled-unicast


   route-policy allow-all in


   route-policy allow-all out


route-policy allow-all


 pass


 end


router static

 address-family ipv4 unicast

  23.0.0.3/32 gi0/0/0/1

!

router bgp 200

 address-family vpnv4 unicast

 neighbor 7.7.7.7

  remote-as 200


  update-source lo0


  address-family vpnv4 unicast

!

vrf DEF


 address-family ipv4 unicast


  export route-target 2:2


  import route-target 2:2


router bgp 200


 vrf DEF

  rd 2:2

int gi0/0/0/0

 no ipv4 address 12.0.0.2 255.255.255.0

 vrf DEF

 ipv4 address 12.0.0.2 255.255.255.0

!

router rip

 vrf DEF

  int gi0/0/0/0

  redistribute bgp 200


router bgp 200


 vrf DEF


  address-family ipv4 unicast

   redistribute rip

! R3

mpls ldp

router ospf 1

 router-id 3.3.3.3

 mpls ldp auto-config


 area 0


  int lo0


  int gi0/0/0/1

!

vrf ABC


 address-family ipv4 unicast


  export route-target 1:1


  import route-target 1:1

router bgp 100

 bgp router-id 3.3.3.3

 vrf ABC

  rd 1:1

int gi0/0/0/0

 no ipv4 address 23.0.0.3 255.255.255.0

 vrf ABC

 ipv4 address 23.0.0.3 255.255.255.0

!

router bgp 100


 address-family vpnv4 unicast


 vrf ABC


  address-family ipv4 unicast


   redistribute connected

   allocate-label all

  neighbor 23.0.0.2

   remote-as 200


   address-family ipv4 labeled-unicast


    route-policy allow-all in


    route-policy allow-all out


    as-override


route-policy allow-all


 pass


 end


router static


 vrf ABC

  address-family ipv4 unicast

   23.0.0.2/32 gi0/0/0/1

!

router bgp 100

 neighbor 6.6.6.6


  remote-as 100


  update-source lo0


  address-family vpnv4 unicast

! R4

mpls ldp


router ospf 1


 router-id 4.4.4.4


 mpls ldp auto-config


 area 0

  int lo0

  int gi0/0/0/0

  int gi0/0/0/1

! R5

mpls label protocol ldp


mpls ldp router-id lo0 force


int lo0


 ip ospf 1 area 0


int e1/0

 ip ospf 1 area 0

int e1/1

 ip ospf 1 area 0

router ospf 1

 router-id 5.5.5.5

 mpls ldp autoconfig

! R6

mpls label protocol ldp


mpls ldp router-id lo0 force


int lo0

 ip ospf 1 area 0

int e1/0

 ip ospf 1 area 0


router ospf 1


 router-id 6.6.6.6


 mpls ldp autoconfig

!

vrf definition ABC


 rd 1:1


 address-family ipv4


  route-target both 1:1


int e1/1


 vrf forwarding ABC

 ip address 67.0.0.6 255.255.255.0

!

router bgp 100


 bgp router-id 6.6.6.6


 no bgp default ipv4-unicast


 address-family ipv4 vrf ABC

  neighbor 67.0.0.7 remote-as 200

  neighbor 67.0.0.7 activate

  neighbor 67.0.0.7 as-override

  neighbor 67.0.0.7 send-label

  redistribute connected

!

router bgp 100

 neighbor 3.3.3.3 remote-as 100

 neighbor 3.3.3.3 update-source lo0

 address-family vpnv4

  neighbor 3.3.3.3 activate

  neighbor 3.3.3.3 send-community extended

! R7

router bgp 200

 address-family ipv4 unicast

  network 7.7.7.7/32

  allocate-label all

 neighbor 67.0.0.6

  remote-as 100


  address-family ipv4 labeled-unicast


   route-policy allow-all in


   route-policy allow-all out


route-policy allow-all


 pass


 end


router static

 address-family ipv4 unicast

  67.0.0.6/32 gi0/0/0/1

!

router bgp 200

 address-family vpnv4 unicast

 neighbor 2.2.2.2

  remote-as 200


  update-source lo0


  address-family vpnv4 unicast

!

vrf DEF


 address-family ipv4 unicast


  export route-target 2:2


  import route-target 2:2


router bgp 200


 vrf DEF

  rd 2:2

int gi0/0/0/0

 no ipv4 address 78.0.0.7 255.255.255.0

 vrf DEF

 ipv4 address 78.0.0.7 255.255.255.0

!

router rip

 vrf DEF

  int gi0/0/0/0

  redistribute bgp 200


router bgp 200


 vrf DEF


  address-family ipv4 unicast


   redistribute rip

! R8

router rip

 version 2

 network 78.0.0.0

 network 8.0.0.0

Verification:

! R1

sh rip database

sh ip route rip

ping 8.8.8.8

! R2

sh bgp ipv4 labeled-unicast sum

sh bgp ipv4 labeled-unicast

sh route bgp

sh route static

ping 7.7.7.7

sh bgp vpnv4 u sum

sh bgp vpnv4 u

sh vrf DEF detail

sh rip vrf DEF database

! R3

sh ospf int bri

sh ospf nei

sh route ospf

sh mpls int

sh mpls ldp nei bri

sh mpls ldp dis

sh vrf ABC detail

sh bgp vrf ABC ipv4 labeled-unicast sum

sh bgp vrf ABC ipv4 labeled-unicast

sh route vrf ABC static

sh bgp vpnv4 u sum

sh bgp vpnv4 u

sh route vrf ABC bgp

sh mpls forwarding

! R4

sh ospf int bri

sh ospf nei

sh route ospf

sh mpls int

sh mpls ldp nei bri

sh mpls ldp dis

! R5

sh ip ospf int bri

sh ip ospf nei

sh ip route ospf

sh mpls int

sh mpls ldp nei

sh mpls ldp dis

! R6

sh ip ospf int bri

sh ip ospf nei

sh ip route ospf

sh mpls int

sh mpls ldp nei

sh mpls ldp dis

sh vrf detail

sh bgp vrf ABC all sum

sh bgp vrf ABC all

sh bgp vpnv4 u all sum

sh bgp vpnv4 u all

sh mpls forwarding

! R7

sh bgp ipv4 labeled-unicast sum

sh bgp ipv4 labeled-unicast

sh route bgp

sh route static

ping 2.2.2.2

sh bgp vpnv4 u sum

sh bgp vpnv4 u

sh vrf DEF detail

sh rip vrf DEF database

! R8

sh rip database

sh ip route rip

ping 1.1.1.1

Comments are closed.

This entry was posted on Friday, October 26th, 2018 at 9:44 pm and is filed under CCIE. You can follow any responses to this entry through the RSS 2.0 feed. Responses are currently closed, but you can trackback from your own site.