Aut inveniam viam aut faciam

Inter-AS VPN Option (10) A Notes

Inter-AS VPN Option (10) A

 – Back-to-back VRF

     -> The client’s routes are exhchanged by ASBRs by configuring each other as VRF clients

          -> ASBR1 <–> ASBR2

     -> This solution can have scalability issues as one layer 3 interface / VRF will be required on the ASBRs

     -> The client routes are sent by the PE router to the ASBR router over VPNv4 neighbor connection

R1(config)# vrf definition ABC

 rd 1:1

 address-family ipv4 unicast

  route-target both 1:1

int s0/0

 vrf forwarding ABC

router eigrp 1

 address-family ipv4 vrf ABC

  network 14.0.0.1 0.0.0.0

  redistribute bgp 100 metric 1 1 1 1 1

router bgp 100

 no bgp default ipv4-unicast

 neighbor 3.3.3.3 remote-as 100

 neighbor 3.3.3.3 update-source lo0

 address-family vpnv4 unicast

  neighbor 3.3.3.3 activate

 address-family ipv4 vrf ABC

 redistribute eigrp 1

XR Router

R3(config)# vrf ABC

 address-family ipv4 unicast

  import route-target 1:1

  export route-target 1:1

int s0/1

 no ipv4 add

 vrf ABC

 ipv4 add <ip add>

router eigrp 1

 vrf ABC

  address-family ipv4 unicast

   autonomous-system 1

   int s0/1

   redistribute bgp 100

    default-metric 1 1 1 1 1

router bgp 100

 address-family ipv4 unicast

 address-family vpnv4 unicast

 neighbor 1.1.1.1

  remote-as 100

  update-source lo0

  address-family vpnv4 unicast

 vrf ABC

  rd 1:1

  address-family ipv4 unicast

  redistribute eigrp 1

Rinse and repeat for R5 and R7

! R1

router eigrp 1

 eigrp router-id 1.1.1.1

 network 1.1.1.1 0.0.0.0

 network 12.0.0.1 0.0.0.0

! R2

mpls label protocol ldp


mpls ldp router-id lo0 force


int lo0


 ip ospf 100 area 0


int e1/0


 ip ospf 100 area 0

router ospf 100

 router-id 2.2.2.2

 mpls ldp autoconfig

!

vrf definition ABC


 rd 1:1


 address-family ipv4

  route-target both 1:1

int e1/1

 vrf forwarding ABC

 ip address 12.0.0.2 255.255.255.0

!

router eigrp 1

 eigrp router-id 2.2.2.2

 address-family ipv4 vrf ABC


  autonomous-system 1


  network 12.0.0.2 0.0.0.0

!

router bgp 100

 bgp router-id 2.2.2.2

 no bgp default ipv4-unicast

 neighbor 4.4.4.4 remote-as 100

 neighbor 4.4.4.4 update-source lo0

 address-family vpnv4

  neighbor 4.4.4.4 activate

  neighbor 4.4.4.4 send-community extended

!

router eigrp 1


 address-family ipv4 vrf ABC


  redistribute bgp 100 metric 1 1 1 1 1


router bgp 100

 address-family ipv4 vrf ABC

  redistribute eigrp 1

! R3

mpls ldp

router ospf 100

 router-id 3.3.3.3

 mpls ldp auto-config


 area 0

  int lo0

  int gi0/0/0/0

  int gi0/0/0/1

! R4

mpls ldp

router ospf 100

 router-id 4.4.4.4

 mpls ldp auto-config


 area 0

  int lo0

  int gi0/0/0/0

!

vrf ABC


 address-family ipv4 unicast


  export route-target 1:1

  import route-target 1:1

int gi0/0/0/1

 no ipv4 address 45.0.0.4 255.255.255.0

 vrf ABC

 ipv4 address 45.0.0.4 255.255.255.0

router bgp 100


 vrf ABC


  rd 1:1

!

router bgp 100

 bgp router-id 4.4.4.4

 address-family vpnv4 unicast

 neighbor 2.2.2.2

  remote-as 100


  update-source lo0


  address-family vpnv4 unicast

!

router bgp 100


 vrf ABC


  address-family ipv4 unicast


   redistribute eigrp 1


router eigrp 1


 vrf ABC


  address-family ipv4


  default-metric 1 1 1 1 1


  autonomous-system 1


  redistribute bgp 100


  int gi0/0/0/1

! R5

mpls ldp

router ospf 200

 router-id 5.5.5.5

 mpls ldp auto-config


 area 0

  int lo0

  int gi0/0/0/0

!

vrf DEF


 address-family ipv4 unicast


  export route-target 2:2

  import route-target 2:2

int gi0/0/0/1

 no ipv4 address 45.0.0.5 255.255.255.0

 vrf DEF

 ipv4 address 45.0.0.5 255.255.255.0

router bgp 200


 vrf DEF


  rd 2:2

!

router bgp 200

 bgp router-id 5.5.5.5

 address-family vpnv4 unicast

 neighbor 7.7.7.7

  remote-as 200


  update-source lo0


  address-family vpnv4 unicast

!

router bgp 200


 vrf DEF


  address-family ipv4 unicast


   redistribute eigrp 1


router eigrp 1


 vrf DEF


  address-family ipv4


   default-metric 1 1 1 1 1


   autonomous-system 1


   redistribute bgp 200


   int gi0/0/0/1

! R6

mpls label protocol ldp

mpls ldp router-id lo0 force

int lo0

 ip ospf 200 area 0


int e1/0

 ip ospf 200 area 0

int e1/1

 ip ospf 200 area 0

router ospf 200

 router-id 6.6.6.6

 mpls ldp autoconfig

! R7

mpls label protocol ldp


mpls ldp router-id lo0 force


int lo0

 ip ospf 200 area 0

int e1/0

 ip ospf 200 area 0

router ospf 200

 router-id 7.7.7.7

 mpls ldp autoconfig

!

vrf definition DEF


 rd 2:2


 address-family ipv4

  route-target both 2:2

int e1/1

 vrf forwarding DEF

 ip address 78.0.0.7 255.255.255.0

!

router eigrp 1

 eigrp router-id 7.7.7.7

 address-family ipv4 vrf DEF

  autonomous-system 1

  network 78.0.0.7 0.0.0.0

!

router bgp 200

 bgp router-id 7.7.7.7

 no bgp default ipv4-unicast

 neighbor 5.5.5.5 remote-as 200

 neighbor 5.5.5.5 update-source lo0

 address-family vpnv4

  neighbor 5.5.5.5 activate

  neighbor 5.5.5.5 send-community extended

!

router eigrp 1


 address-family ipv4 vrf DEF


  redistribute bgp 200 metric 1 1 1 1 1


router bgp 200


 address-family ipv4 vrf DEF


  redistribute eigrp 1

! R8

router eigrp 1

 address-family ipv4

  router-id 8.8.8.8

  int lo0

  int gi0/0/0/0

Verification:

! R1

sh ip eigrp int

sh ip eigrp nei

sh ip route eigrp

ping 8.8.8.8

! R2 and R7

sh ip ospf int bri

sh ip ospf nei

sh ip route ospf

sh mpls int

sh mpls ldp nei

sh mpls ldp dis

sh bgp vpnv4 u all sum

sh vrf detail

sh vrf DEF

sh ip eigrp vrf DEF int

sh ip eigrp vrf DEF nei

sh ip route vrf DEF eigrp

sh bgp vrf DEF

sh ip route vrf DEF bgp

sh ip eigrp vrf DEF topology

sh bgp vpnv4 u all

sh bgp vpnv4 u all labels

sh mpls forwarding

! R3

sh ospf int bri

sh ospf nei

sh route ospf

sh mpls int

sh mpls ldp nei bri

sh mpls ldp dis

! R4

sh ospf int bri

sh ospf nei

sh mpls int

sh mpls ldp nei bri

sh mpls ldp dis

sh bgp vpnv4 u sum

sh vrf ABC

sh vrf ABC detail

sh ip vrf ABC int bri

sh eigrp vrf ABC int

sh eigrp vrf ABC nei

sh route vrf ABC eigrp

sh bgp vrf ABC

sh route vrf ABC bgp

sh eigrp vrf ABC topology

sh mpls forwarding

sh bgp vpnv4 u

sh bgp vpnv4 u labels

! R5

sh ospf int bri

sh ospf nei

sh mpls int

sh mpls ldp nei bri

sh mpls ldp dis

sh bgp vpnv4 u sum

sh bgp vpnv4 u

sh vrf DEF

sh vrf DEF detail

sh ip vrf DEF int bri

sh eigrp vrf DEF int

sh eigrp vrf DEF nei

sh route vrf DEF eigrp

sh bgp vrf DEF

sh route vrf DEF bgp

sh eigrp vrf DEF topology

sh mpls forwarding

sh bgp vpnv4 u

sh bgp vpnv4 u labels

! R6

sh ip ospf int bri

sh ip ospf nei

sh ip route ospf

sh mpls int

sh mpls ldp nei

sh mpls ldp dis

! R8

sh eigrp int

sh eigrp nei

sh route eigrp

ping 1.1.1.1




Comments are closed.

This entry was posted on Friday, October 26th, 2018 at 10:02 pm and is filed under CCIE. You can follow any responses to this entry through the RSS 2.0 feed. Responses are currently closed, but you can trackback from your own site.